autogeekonline car wax, car care and auto detailing forum Autogeek on TV
car wax, car care and auto detailing forumAutogeekonline autogeekonline car wax, car care and auto detailing forum HomeForumBlogAutogeek.net StoreDetailing Classes with Mike PhillipsGalleryDetailing How To's
Thanks Thanks:  0
Dislikes Dislikes:  0
Page 3 of 3 FirstFirst 123
Results 21 to 26 of 26
  1. #21
    Senior Member KirkH's Avatar
    Join Date
    Nov 2016
    Location
    KY
    Posts
    848
    Post Thanks / Like

    Re: Tornador Black starts with low power, spins up to full than drops again

    You will want to put a moisture filter on it. There is some oil in the tank, and if you do get some rust, the water that comes out will stain.


    Sent from my iPhone using AGOnline
    Kirk Harrod, Bitchin' Camaro Mobile Detailing, Frankfort, KY
    on Instagram: bitchincamarodetailing
    camarodetail@yahoo.com

  2. #22
    Senior Member LSNAutoDetailing's Avatar
    Join Date
    Jun 2014
    Location
    Chandler, AZ
    Posts
    2,378
    Post Thanks / Like

    Re: Tornador Black starts with low power, spins up to full than drops again

    Quote Originally Posted by KirkH View Post
    Q1. havent timed it but im going to estimate 3 minites.


    Sent from my iPhone using AGOnline

    Well either I was playing with the Tornador too much while it was trying to fill or something is not right. It ran for about 30 minutes.

    Iíll try it again tomorrow and not run the tool.


    Sent from my iPhone using Autogeekonline mobile app

    Paul_G www.lsnautodetail.com IDA CD-SV

  3. #23
    Senior Member KirkH's Avatar
    Join Date
    Nov 2016
    Location
    KY
    Posts
    848
    Post Thanks / Like

    Re: Tornador Black starts with low power, spins up to full than drops again

    Quote Originally Posted by LSNAutoDetailing View Post
    Well either I was playing with the Tornador too much while it was trying to fill or something is not right. It ran for about 30 minutes.

    Iíll try it again tomorrow and not run the tool.


    Sent from my iPhone using Autogeekonline mobile app
    Oh it may run the whole time if youre using the tornador. Its an airhog.


    Sent from my iPhone using Autogeekonline mobile app
    Kirk Harrod, Bitchin' Camaro Mobile Detailing, Frankfort, KY
    on Instagram: bitchincamarodetailing
    camarodetail@yahoo.com

  4. #24
    Junior Member
    Join Date
    Sep 2017
    Location
    NH
    Posts
    9
    Post Thanks / Like

    Re: Tornador Black starts with low power, spins up to full than drops again

    WD-40 on the spinner if you haven't already. I have the black and also the vac attachment with a nice 60 gal compressor and I've had this issue before. Keeping it lubricated after every car has worked for me.

  5. #25
    Senior Member LSNAutoDetailing's Avatar
    Join Date
    Jun 2014
    Location
    Chandler, AZ
    Posts
    2,378
    Post Thanks / Like

    Re: Tornador Black starts with low power, spins up to full than drops again

    Quote Originally Posted by Kiddersdetailing View Post
    WD-40 on the spinner if you haven't already. I have the black and also the vac attachment with a nice 60 gal compressor and I've had this issue before. Keeping it lubricated after every car has worked for me.
    Thanks, the TB is fine and spinning as normal, the issue was with the Compressor... Replaced compressor...

    Paul_G www.lsnautodetail.com IDA CD-SV

  6. #26
    Senior Member LSNAutoDetailing's Avatar
    Join Date
    Jun 2014
    Location
    Chandler, AZ
    Posts
    2,378
    Post Thanks / Like

    Re: Tornador Black starts with low power, spins up to full than drops again

    Quote Originally Posted by PaulMys View Post
    Nice buy Paul!!

    I'm not sure on Q1, but I would think it should only take about a minute or two for that to fill up.

    As for Q2, and this is JMO, I would drain it after every use. Especially with the difference in AZ between the ambient air temps.

    I've always found the hotter the outside air, the more condensate was created in our compressor tanks.
    Quote Originally Posted by KirkH View Post
    Q1. havent timed it but im going to estimate 3 minites.


    Sent from my iPhone using AGOnline

    Yup, finally tested the fill time. Took between 3 and 5 minutes to get to 150 PSI. My regulator held fast at 100 PSI.
    Then I started using the Tornador, took about a minute or two of use before the PSI dropped from 150 to 125.
    I timed it from 125 to 150 and that takes about 2 to 2.5 minutes.

    125 seems to be the magic mark where the compressor likes to kick back on... and with that said, I still had a constant 100 PSI to the tool. (of course it drops when you pull the trigger, but goes right back to 100).

    We'll see how she works tomorrow... Got a 911 Turbo in need of serious TLC coming in tomorrow! Show-n-shine to follow..

    Paul_G www.lsnautodetail.com IDA CD-SV

  7. Likes PaulMys liked this post
Page 3 of 3 FirstFirst 123

Similar Threads

  1. Tornador Velocity-Vac and Tornador Black?
    By Mantilgh in forum Hot topics & Frequently Asked Questions
    Replies: 5
    Last Post: 02-13-2016, 04:31 PM
  2. Black drops stuck on paint...
    By MaXGTS in forum Ask Mike Phillips your detailing questions!
    Replies: 4
    Last Post: 08-22-2014, 04:03 PM
  3. Tornador Black
    By Triple Shine in forum Ask Mike Phillips your detailing questions!
    Replies: 0
    Last Post: 12-02-2013, 08:32 PM
  4. Replies: 7
    Last Post: 05-08-2013, 12:53 PM
  5. Replies: 5
    Last Post: 01-13-2012, 06:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

» December 2017

2627282930 1 2
3 4 5 6 7 8 9
10 11 12 13 14 15 16
17 18 19 20 21 22 23
24 25 26 27 28 29 30
31 123456