autogeekonline car wax, car care and auto detailing forum Autogeek on TV
car wax, car care and auto detailing forumAutogeekonline autogeekonline car wax, car care and auto detailing forum HomeForumBlogAutogeek.net StoreDetailing Classes with Mike PhillipsGalleryDetailing How To's
Results 1 to 9 of 9
  1. #1
    Senior Member Thenissanguy's Avatar
    Join Date
    Sep 2014
    Location
    SoCal
    Posts
    137

    Help ! Ran into a problem

    Yesterday i started the rear door of the trailer, i washed it and dried it then followed up with the meguiars flagship premium wax(by hand) and wow it came our amazing! but today I was waxing the side of my Rv (toyhauler with gelcoat) today in the morning and i noticed when i tried to buff off the was it was very hard to remove and dried up rather quick. Some spots were shiny and some were very dull . I got a few pictures to give you an idea of the problem i am facing......






    Help ! Ran into a problem-image1.jpgHelp ! Ran into a problem-image2.jpg

  2. #2
    Senior Member
    Join Date
    Dec 2011
    Location
    Reisterstown MD
    Posts
    994

    Re: Help ! Ran into a problem

    Re apply it but wipe it right off. I think the gel coat is probably dry

  3. #3
    Senior Member Thenissanguy's Avatar
    Join Date
    Sep 2014
    Location
    SoCal
    Posts
    137

    Re: Help ! Ran into a problem

    ok i will try that right now see if it fixes my problem .
    UPDATE: that did nothing , still looks the same
    Last edited by Thenissanguy; 10-09-2016 at 02:01 PM. Reason: Update

  4. #4
    Senior Member
    Join Date
    Sep 2015
    Posts
    6,249

    Re: Help ! Ran into a problem

    Quote Originally Posted by Mike lambert View Post
    Re apply it but wipe it right off. I think the gel coat is probably dry
    Agree.

  5. #5
    Senior Member
    Join Date
    Sep 2015
    Posts
    6,249

    Re: Help ! Ran into a problem

    Quote Originally Posted by Thenissanguy View Post
    ok i will try that right now see if it fixes my problem .
    UPDATE: that did nothing , still looks the same
    You need a process to clean and rejuvenate the gelcoat.The wax is drying in the gelcoat.None of this is achievable by hand.

  6. #6
    Senior Member Thenissanguy's Avatar
    Join Date
    Sep 2014
    Location
    SoCal
    Posts
    137

    Re: Help ! Ran into a problem

    Quote Originally Posted by GSKR View Post
    You need a process to clean and rejuvenate the gelcoat.The wax is drying in the gelcoat.None of this is achievable by hand.
    Can you elaborate more on this...?

  7. #7
    Senior Member Thenissanguy's Avatar
    Join Date
    Sep 2014
    Location
    SoCal
    Posts
    137

    Re: Help ! Ran into a problem

    Do i need a dual action polisher for this ?

  8. #8
    Senior Member
    Join Date
    Sep 2015
    Posts
    6,249

    Re: Help ! Ran into a problem

    Yes if you want to pull out the oxidation.On those trailers the paint is really thin.Stick with the menzerna line for gelcoat.Staining with colored polishes are a promblem it will stain.menzerna 3 in one should be fine with the pics you posted.Even though it's a aio which means it cuts polishes and seal,I would go over it anyway with a quality wax like collinite 845.Griots has a finishing sealant used in conjunction with your da .It has great reviews but I haven't tried it yet.when you get your da slow steady arm speed,other wise you will get highs and low spots.Stick with foam buff and shine pads.micro pads generate to much heat on gel coat,and matting happens which means it won't shine kinda like flat paint with a little gloss to it.

  9. #9
    Senior Member Thenissanguy's Avatar
    Join Date
    Sep 2014
    Location
    SoCal
    Posts
    137

    Re: Help ! Ran into a problem

    Quote Originally Posted by GSKR View Post
    Yes if you want to pull out the oxidation.On those trailers the paint is really thin.Stick with the menzerna line for gelcoat.Staining with colored polishes are a promblem it will stain.menzerna 3 in one should be fine with the pics you posted.Even though it's a aio which means it cuts polishes and seal,I would go over it anyway with a quality wax like collinite 845.Griots has a finishing sealant used in conjunction with your da .It has great reviews but I haven't tried it yet.when you get your da slow steady arm speed,other wise you will get highs and low spots.Stick with foam buff and shine pads.micro pads generate to much heat on gel coat,and matting happens which means it won't shine kinda like flat paint with a little gloss to it.
    Thanks i will see if my budget allows for for a DA right now funds are a little tight . I applied a little but of chemical guys classic paste wax and it shined really well there were no dry spots just the shine i was looking for .... Do you know why is that?

Similar Threads

  1. Have a problem
    By Prophizee in forum Auto Detailing 101
    Replies: 2
    Last Post: 08-27-2014, 11:09 AM
  2. Big Problem
    By Sixbanger in forum Ask Mike Phillips your detailing questions!
    Replies: 9
    Last Post: 07-06-2014, 06:57 AM
  3. New Guy Problem
    By thenewguy in forum Auto Detailing 101
    Replies: 19
    Last Post: 06-20-2014, 07:49 AM
  4. TSR Problem
    By man_karat in forum Wolfgang Car Care
    Replies: 4
    Last Post: 04-20-2009, 02:39 PM
  5. LC pad problem... HELP!
    By Marc08EX in forum Porter Cable 7424XP Dual Action Orbital Polisher
    Replies: 2
    Last Post: 05-21-2008, 10:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

» September 2017

2728293031 1 2
3 4 5 6 7 8 9
10 11 12 13 14 15 16
17 18 19 20 21 22 23
24 25 26 27 28 29 30