autogeekonline car wax, car care and auto detailing forum Autogeek on TV
car wax, car care and auto detailing forumAutogeekonline autogeekonline car wax, car care and auto detailing forum HomeForumBlogAutogeek.net StoreDetailing Classes with Mike PhillipsGalleryDetailing How To's
 

» Detailing Classes

New Dates Available for the Autogeek Roadshow!
Page 1 of 2 12 LastLast
Results 1 to 10 of 19
  1. #1
    Senior Member DetailKitty's Avatar
    Join Date
    Jul 2013
    Location
    PA
    Posts
    4,512
    Post Thanks / Like

    Not sure if I have an issue

    I hadn't used my Rupes Mini in quite a while. When I first got it I found I was putting way too much pressure on it and it was only rotating but didn't have that "dual action" rotation. Posting on here people assured me it was due to too much pressure.
    Got it.

    Well this time I had ZERO pressure on it and it wasn't occilating. Most of the time it was only rotating. I had to almost lift it off the paint to get the dual action working.
    Am I still not using it properly or do I possibly have a defective/broken machine?

    Advice is appreciated.

    Thx in advance.

    2019 Ford Escape SE 2016 Alfa Romeo 4C Spider 2006 Buell Lightning-bolt 2017 Ford Focus RS

  2. #2
    Senior Member
    Join Date
    Aug 2014
    Posts
    1,435
    Post Thanks / Like

    Re: Not sure if I have an issue

    If you are using an extension cord, try plugging into a socket directly to observe any changes. Let's try to remove some variables first.
    "I've seen a good quality car wash look better than some guys complete detail jobs."
    Mike Phillips 10/21/09

  3. #3
    Senior Member DetailKitty's Avatar
    Join Date
    Jul 2013
    Location
    PA
    Posts
    4,512
    Post Thanks / Like

    Re: Not sure if I have an issue

    Quote Originally Posted by expdetailing View Post
    If you are using an extension cord, try plugging into a socket directly to observe any changes. Let's try to remove some variables first.
    I was, so I will try that, although it won't give me a lot of working room.

    2019 Ford Escape SE 2016 Alfa Romeo 4C Spider 2006 Buell Lightning-bolt 2017 Ford Focus RS

  4. #4
    Senior Member custmsprty's Avatar
    Join Date
    Apr 2012
    Posts
    7,306
    Post Thanks / Like

    Re: Not sure if I have an issue

    Quote Originally Posted by DetailKitty View Post
    I was, so I will try that, although it won't give me a lot of working room.
    As long as you are using the proper rated extension cord that should have no effect. I used mine with a 25 foot 14 gauge Husky extension cord when I did my new Rougue and it worked fine. I now use the Griots pads instead of the Rupes when polishing.
    2013 Genesis Coupe 3.8 Track Edition
    2015 Hyundai Sonata Limited, 2016 Pearl White Nissan Altima SR
    2019 Nissan Rogue SL

  5. #5
    Senior Member vobro's Avatar
    Join Date
    Jun 2012
    Location
    Homer Glen Il
    Posts
    725
    Post Thanks / Like

    Re: Not sure if I have an issue

    What pads are you using? I had issues with stalling also and found the Meg's 3" mf pads to be the best. Also consider where you are using the mini, usually in small curved areas that are prone to stalling. Take the time to move the back of handle to adjust polisher so that you can follow the panel. I hardly use mine anymore because to me it's the weakest Rupes and frustrates me, I use the mini Flex more

  6. #6
    Senior Member
    Join Date
    Dec 2018
    Posts
    1,231
    Post Thanks / Like

    Re: Not sure if I have an issue

    I read that with the mini (stalls) but that seems wierd. Are you making sure even with no pressure your not tilting it? I would try holding dircectly on top of DA over the pad on flat surface. Use other hand to move handle/base around to make sure it is not tilted. Probably in need of warranty service.


    Sent from my iPhone using Tapatalk

  7. #7
    Senior Member DetailKitty's Avatar
    Join Date
    Jul 2013
    Location
    PA
    Posts
    4,512
    Post Thanks / Like

    Re: Not sure if I have an issue

    Quote Originally Posted by custmsprty View Post
    As long as you are using the proper rated extension cord that should have no effect. I used mine with a 25 foot 14 gauge Husky extension cord when I did my new Rougue and it worked fine. I now use the Griots pads instead of the Rupes when polishing.
    I wouldn't think so either but why not give it a try, right?

    Quote Originally Posted by vobro View Post
    What pads are you using? I had issues with stalling also and found the Meg's 3" mf pads to be the best. Also consider where you are using the mini, usually in small curved areas that are prone to stalling. Take the time to move the back of handle to adjust polisher so that you can follow the panel. I hardly use mine anymore because to me it's the weakest Rupes and frustrates me, I use the mini Flex more
    They are Rupes pads. It definitely happened a lot going through curved areas. I am used to Flex machines so it's frustrating to me as well... I'm 5'1 and way 114lbs? How hard could I possibly be pressing???

    Quote Originally Posted by Coatingsarecrack View Post
    I read that with the mini (stalls) but that seems wierd. Are you making sure even with no pressure your not tilting it? I would try holding dircectly on top of DA over the pad on flat surface. Use other hand to move handle/base around to make sure it is not tilted. Probably in need of warranty service.
    I do hold directly over the pad area... my standard DA hold on all my machines
    I was being very "strict" with hold and position once it started happening frequently. It COULD be it's tilting a bit but I'm not sure how much straighter I could hold it.

    Thx for the responses gang. For an expensive machine I'm a bit annoyed with it.
    I understand it's a smaller machine, so that could be a major factor, but (and not to sound like a total jerk) my $50 Harbor Freight never had this many issues.

    2019 Ford Escape SE 2016 Alfa Romeo 4C Spider 2006 Buell Lightning-bolt 2017 Ford Focus RS

  8. #8
    Senior Member BSoares's Avatar
    Join Date
    Mar 2017
    Location
    Exton, PA
    Posts
    1,032
    Post Thanks / Like

    Re: Not sure if I have an issue

    I would think pressure is not the issue since you said its rotating but not oscillating. Pressure causes the opposite, the pad oscillates but stops spinning.

    If its under warranty call Rupes. Maybe create a video of the issue so people can see whats really going on. Ive never used a mini so I dont know how much power it has.
    Bruno Soares


  9. Likes Coatingsarecrack liked this post
  10. #9
    Senior Member DetailKitty's Avatar
    Join Date
    Jul 2013
    Location
    PA
    Posts
    4,512
    Post Thanks / Like

    Re: Not sure if I have an issue

    Quote Originally Posted by BSoares View Post
    I would think pressure is not the issue since you said it’s rotating but not oscillating. Pressure causes the opposite, the pad oscillates but stops spinning.

    If it’s under warranty call Rupes. Maybe create a video of the issue so people can see what’s really going on. I’ve never used a mini so I don’t know how much power it has.
    Good idea. Not sure if it's still under warranty at this point but worth a shot.

    2019 Ford Escape SE 2016 Alfa Romeo 4C Spider 2006 Buell Lightning-bolt 2017 Ford Focus RS

  11. #10
    Senior Member
    Join Date
    Dec 2018
    Posts
    1,231
    Post Thanks / Like

    Re: Not sure if I have an issue

    Quote Originally Posted by BSoares View Post
    I would think pressure is not the issue since you said its rotating but not oscillating. Pressure causes the opposite, the pad oscillates but stops spinning.

    If its under warranty call Rupes. Maybe create a video of the issue so people can see whats really going on. Ive never used a mini so I dont know how much power it has.
    In my head I was seeing opposite. Great observation. If its not oscillating definetly failure


    Sent from my iPhone using Tapatalk

Page 1 of 2 12 LastLast

Similar Threads

  1. OK, seems like i have a issue here
    By Richs66 in forum Auto Detailing 101
    Replies: 8
    Last Post: 07-11-2017, 10:42 AM
  2. 845 Issue
    By Zubair in forum Auto Detailing 101
    Replies: 3
    Last Post: 11-11-2014, 08:09 AM
  3. DG 501 Issue?
    By BTLew81 in forum Auto Detailing 101
    Replies: 11
    Last Post: 05-11-2012, 12:22 PM
  4. What's the issue here?
    By aerogt01 in forum Porter Cable 7424XP Dual Action Orbital Polisher
    Replies: 31
    Last Post: 10-20-2011, 09:50 PM
  5. I've got an issue....
    By ALLN1WASH in forum Ask Mike Phillips your detailing questions!
    Replies: 2
    Last Post: 03-24-2011, 08:10 PM

Members who have read this thread: 91

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

» October 2019

S M T W T F S
2930 1 2 3 4 5
6 7 8 9 10 11 12
13 14 15 16 17 18 19
20 21 22 23 24 25 26
27 28 29 30 31 12