autogeekonline car wax, car care and auto detailing forum Autogeek on TV
car wax, car care and auto detailing forumAutogeekonline autogeekonline car wax, car care and auto detailing forum HomeForumBlogAutogeek.net StoreDetailing Classes with Mike PhillipsGalleryDetailing How To's
 

» Detailing Classes

New Dates Available for the Autogeek Roadshow!
Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 4 of 4

Thread: Broken 3401?

  1. #1
    Junior Member
    Join Date
    Feb 2020
    Posts
    17
    Post Thanks / Like

    Broken 3401?

    Well, this happened.
    Anyone else have a problem like this? I bought this maybe 6 months ago.
    It still works but starting to get noisy.
    Attached Thumbnails Attached Thumbnails Broken 3401?-20201130_143740_copy_567x1008-jpg  

  2. #2
    Senior Member JustJesus's Avatar
    Join Date
    Oct 2014
    Location
    Orange & LA Counties
    Posts
    1,187
    Post Thanks / Like

    Re: Broken 3401?

    Does it still spin? Or is there some odd grinding sound?

    Sent from my SM-N960U using Tapatalk

  3. #3
    Director of Training Mike Phillips's Avatar
    Join Date
    Jun 2009
    Location
    Stuart, Florida
    Posts
    49,321
    Post Thanks / Like

    Re: Broken 3401?

    Quote Originally Posted by Stlchucky View Post

    Well, this happened.

    Anyone else have a problem like this? I bought this maybe 6 months ago.

    It still works but starting to get noisy.

    I've never seen anything like this in the entire time I've used the BEAST?

    Here's your picture,




    I'll send the link to this thread to Chris at FLEX.


    Mike Phillips
    Director of Training Autogeek & Marine 31
    IDA Board Member - Certified Detailer - Skills Validated Detailer - IDA Recognized Trainer
    Mike Phillips Facebook Page
    Twitter
    Instagram
    Mike Phillips Detail Training Credentials
    Sign-up for Mike's Tips & Techniques Newsletter


  4. #4
    Director of Training Mike Phillips's Avatar
    Join Date
    Jun 2009
    Location
    Stuart, Florida
    Posts
    49,321
    Post Thanks / Like

    Re: Broken 3401?




    I sent Chris the link to this thread, here's his reply,





    It could be extra grease from when they put in the bearing in the factory that is just squeeze out but it can also be a failed seal that holds in the grease in the gears. May need to be send into Powerhouse for repair.

    Maybe wipe the grease away and see if it keeps coming back. If it does it will need to go in for service.


    Parts for XC3401VRG | Powerhouse Distributing


    Chris









    Mike Phillips
    Director of Training Autogeek & Marine 31
    IDA Board Member - Certified Detailer - Skills Validated Detailer - IDA Recognized Trainer
    Mike Phillips Facebook Page
    Twitter
    Instagram
    Mike Phillips Detail Training Credentials
    Sign-up for Mike's Tips & Techniques Newsletter


Similar Threads

  1. Broken Backing Plate on FLEX 3401? Need for repair?
    By Mike Phillips in forum Ask Mike Phillips your detailing questions!
    Replies: 10
    Last Post: 05-16-2018, 05:21 PM
  2. Broken?
    By Trevor in forum Porter Cable 7424XP Dual Action Orbital Polisher
    Replies: 10
    Last Post: 08-11-2015, 03:00 AM
  3. MT300 broken already broken
    By Engineered Perf in forum Porter Cable 7424XP Dual Action Orbital Polisher
    Replies: 2
    Last Post: 07-25-2015, 09:33 PM
  4. GG6 is Broken...
    By KJW Detailing in forum Porter Cable 7424XP Dual Action Orbital Polisher
    Replies: 12
    Last Post: 10-20-2013, 06:41 PM
  5. UDM is Broken
    By tommy in forum Porter Cable 7424XP Dual Action Orbital Polisher
    Replies: 21
    Last Post: 11-20-2007, 03:09 PM

Members who have read this thread: 38

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

» January 2021

S M T W T F S
2728293031 1 2
3 4 5 6 7 8 9
10 11 12 13 14 15 16
17 18 19 20 21 22 23
24 25 26 27 28 29 30
31 123456