autogeekonline car wax, car care and auto detailing forum Autogeek on TV
car wax, car care and auto detailing forumAutogeekonline autogeekonline car wax, car care and auto detailing forum HomeForumBlogAutogeek.net StoreDetailing Classes with Mike PhillipsGalleryDetailing How To's
 

» Detailing Classes

New Dates Available for the Autogeek Roadshow!
Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 20
  1. #1
    Senior Member EWtheDETAILER's Avatar
    Join Date
    Sep 2012
    Location
    Princeton, Indiana
    Posts
    341
    Post Thanks / Like

    Major Problems with my New Flex XFE15

    Let me start off this article by saying I'm team Flex all the way and have had great success and durability with multiple Flex products over my past 12years detailing...However, I have used my new XFE15 a total of 5 times since I received it on March 25th, and while buffing a car out this weekend, I had the backing plate and mounting screws completely rip away from the polisher while working. Luckily the car was not damage. I am in touch with Autogeek about potential warranty through Autogeek/Flex but figured I should share incase anyone else has similar issues. It appears to me that mounting points of the backing plate melted/got brittle and the backing plate and pad just ripped away from the polisher head. I don't feel like this is normal wear and tear by any means! I will keep you guys posted.

    Major Problems with my New Flex XFE15-imageuploadedbyagonline1464664085-758311-jpg
    Major Problems with my New Flex XFE15-imageuploadedbyagonline1464664104-767727-jpg
    Major Problems with my New Flex XFE15-imageuploadedbyagonline1464664115-955785-jpg
    Major Problems with my New Flex XFE15-imageuploadedbyagonline1464664128-728912-jpg
    Major Problems with my New Flex XFE15-imageuploadedbyagonline1464664140-433639-jpg
    Major Problems with my New Flex XFE15-imageuploadedbyagonline1464664180-972345-jpg
    Keep Calm... and Detail On!

    Eric

  2. #2
    Senior Member Joe@NextLevelDetail's Avatar
    Join Date
    Jun 2015
    Posts
    1,929
    Post Thanks / Like

    Re: Major Problems with my New Flex XFE15

    Wow thats very strange, thankfully the car wasnt damaged.

    You have nothing to worry about autogeek and flex will resolve the issue i am sure of it.

  3. #3
    Senior Member
    Join Date
    Feb 2011
    Location
    Minot, ND
    Posts
    12,332
    Post Thanks / Like

    Re: Major Problems with my New Flex XFE15

    I've run mine a few times now to get a feel for it.

    Could you expand more on exactly how it happened? I.e., Compounding, polishing, pad used, product, speeds, etc.

  4. #4
    Senior Member EWtheDETAILER's Avatar
    Join Date
    Sep 2012
    Location
    Princeton, Indiana
    Posts
    341
    Post Thanks / Like

    Re: Major Problems with my New Flex XFE15

    Quote Originally Posted by Joe@NextLevelDetail View Post
    Wow thats very strange, thankfully the car wasnt damaged.

    You have nothing to worry about autogeek and flex will resolve the issue i am sure of it.
    Yeah... Nick is working on it currently. I was pretty shocked first that it came apart, and second the amount of damage that occurred. I've put the hurting on my other flex products and they still keep putting out great results after the years of abuse. That's the biggest reason I'm team flex. Great quality and durability.
    Keep Calm... and Detail On!

    Eric

  5. #5
    Senior Member EWtheDETAILER's Avatar
    Join Date
    Sep 2012
    Location
    Princeton, Indiana
    Posts
    341
    Post Thanks / Like

    Re: Major Problems with my New Flex XFE15

    Quote Originally Posted by Mike@DedicatedPerfection View Post
    I've run mine a few times now to get a feel for it.

    Could you expand more on exactly how it happened? I.e., Compounding, polishing, pad used, product, speeds, etc.
    Mike,

    When it broke I was using Mckees 37 360 one step with a orange lake country thin pro orange cutting pad. Speeds from 4-5 on the flex. As it was breaking I heard an abnormal change in RPMs but it was so quick I couldn't react.

    The day before we used it on a boat speed 5 with Mckees 31 heavy cut oxidation remover and an orange pad.

    Love the tool as it is very smooth and offers the ability to cut when needed but also great at finishing.
    Keep Calm... and Detail On!

    Eric

  6. #6
    Senior Member
    Join Date
    Feb 2011
    Location
    Minot, ND
    Posts
    12,332
    Post Thanks / Like

    Re: Major Problems with my New Flex XFE15

    Quote Originally Posted by EWtheDETAILER View Post
    Mike,

    When it broke I was using Mckees 37 360 one step with a orange lake country thin pro orange cutting pad. Speeds from 4-5 on the flex. As it was breaking I heard an abnormal change in RPMs but it was so quick I couldn't react.

    The day before we used it on a boat speed 5 with Mckees 31 heavy cut oxidation remover and an orange pad.

    Love the tool as it is very smooth and offers the ability to cut when needed but also great at finishing.
    Thanks for the follow up Eric.

    Keep us updated on what you find out about the machine.

  7. #7
    Senior Member
    Join Date
    Feb 2011
    Location
    Minot, ND
    Posts
    12,332
    Post Thanks / Like

    Re: Major Problems with my New Flex XFE15

    Eric, any updates on your situation?

  8. #8
    In time out
    Join Date
    Sep 2014
    Location
    Johannesburg,South Africa
    Posts
    1,631
    Post Thanks / Like

    Re: Major Problems with my New Flex XFE15

    Looks like a design fault, long throw stresses on too weak mounting points=fail.

  9. #9
    Senior Member EWtheDETAILER's Avatar
    Join Date
    Sep 2012
    Location
    Princeton, Indiana
    Posts
    341
    Post Thanks / Like

    Re: Major Problems with my New Flex XFE15

    Autogeek has been about as good as it gets so far with this. Unfortunately The Flex XFE7-15 is on back order at Autogeek until mid August... Once Autogeek receives the next shipment, they are going to replace mine with a new one! It's a waiting game, but waiting for a new one is way better than being out one! Big thanks to Nick at Autogeek for all the help!
    Keep Calm... and Detail On!

    Eric

  10. #10
    Senior Member swanicyouth's Avatar
    Join Date
    Mar 2011
    Location
    Limerick, PA
    Posts
    9,385
    Post Thanks / Like

    Re: Major Problems with my New Flex XFE15

    Quote Originally Posted by EWtheDETAILER View Post
    Autogeek has been about as good as it gets so far with this. Unfortunately The Flex XFE7-15 is on back order at Autogeek until mid August... Once Autogeek receives the next shipment, they are going to replace mine with a new one! It's a waiting game, but waiting for a new one is way better than being out one! Big thanks to Nick at Autogeek for all the help!
    You think another of the same machine will be any better?

Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 2
    Last Post: 12-02-2018, 12:49 PM
  2. Problems with my Flex 3401
    By 808_detail_nut in forum Flex Polishers
    Replies: 15
    Last Post: 11-26-2014, 02:17 PM
  3. Problems with Flex XC3401 and LC CCS Pads.....
    By KenSekiguchi in forum Flex Polishers
    Replies: 9
    Last Post: 08-20-2009, 06:36 PM
  4. Flex Problems, NOOOOOOOOOOOOOO!
    By Excessive Detail in forum Porter Cable 7424XP Dual Action Orbital Polisher
    Replies: 31
    Last Post: 05-24-2008, 06:18 PM
  5. Major problems!!!
    By matteo86 in forum Auto Detailing 101
    Replies: 14
    Last Post: 05-11-2007, 11:59 AM

Members who have read this thread: 0

There are no members to list at the moment.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

» July 2020

S M T W T F S
282930 1 2 3 4
5 6 7 8 9 10 11
12 13 14 15 16 17 18
19 20 21 22 23 24 25
26 27 28 29 30 31 1